#The "More than 65535 total parts uploaded for a single object" error upon running an Image-Based Backup plan to Wasabi storage

##Situation:

The Image-Based Backup job pointed to the Wasabi storage fails with the “More than 65535 total parts uploaded for a single object” error.

##Cause:

The issue is related to recently failed attempts to upload the data to Wasabi storage account. By design the multipart upload will be only considered finished only if all the parts of it were uploaded and if these parts properly reformed on the storage into a corresponding piece of the data. When due to any reason some parts do not arrive, multipart upload cannot be re-assembled and the portion that already has been uploaded will stay there for 31 days to give you an option to finish the operation. Uncompleted multipart upload will count toward your used storage space and upon reaching a limit of concurrent parts for multipart uploads it will also trigger the “More than 65535 total parts uploaded for a single object” error.

##Solution:

You can use the CloudBerry Explorer, which is our product for managing files in cloud storages, to delete the unfinished multipart uploads. To do that please follow these steps:

  1. Download and install the CloudBerry Explorer for S3: https://www.msp360.com/explorer/windows/amazon-s3.aspx, it comes with a free 15-day trial.

  2. Use the “File-> New S3 Compatible Accounts-> S3 Compatible” to add your Wasabi storage account.

We recommend adding Wasabi storage accounts using the S3 Compatible option in this article to ensure that you will be able to work with the newest buckets regions that might not yet be supported by the software.

  1. Fill in all the required fields to finalize adding the storage account. You can refer to this article to find the service point URLs for the Wasabi regions.

In case the storage account will be added successfully you will be able to access it via the “Registered Accounts” application window:

  1. After adding your storage account expand the Tools menu and navigate to the Multipart Uploads option:

  2. Select the “S3 Compatible” account that you just added and select the bucket you are running the backup plans to, then select multipart upload from the list by clicking on it, then hit the “Delete” button in order to clean up an unfinished upload.

Before deleting the unfinished multipart uploads make sure that you do not have any active ongoing backup plans pointed to your Wasabi bucket, in order to make sure that you would not delete a portion of the current backup. In case you will delete the multipart upload for an ongoing plan it will result in a failure of that plan.

  1. After the deletion of unfinished multipart uploads start your Image-Based backup plan.

Alternatively, you can refer to this Wasabi documentation that describes how to clean up unfinished multipart uploads via AWS CLI.