Cannot Resolve the Path to Virtual Machine (code 1911)
Situation
A VMware backup plan terminates with the following error: Cannot Resolve the Path to Virtual Machine. The path to a virtual machine {VM name} contains non-supported characters
Cause
VDDK libraries are not localized, but backup partners can support any locale that uses UTF-8 encoding. Other than Unicode, VDDK does not support multibyte character encodings such as Extended Unix Code (EUC) for Chinese, Japanese, and Korean (ISO-2022).
The pathname to a virtual machine and its VMDK can be expressed with any character set supported by the host file system. As of vSphere 4 and Workstation 7, VMware supports Unicode UTF-8 path names, although for portability to various locales, ASCII-only path names are recommended.
Windows 2000 systems (and later) use UTF-16 for localized path names. For example, in locale FR (Français) the VDDK sample code might mount disk at C:\Windows\Temp\vmware-Système, where è is encoded as UTF-16 so the VixMntapi library cannot recognize it. In this case, a workaround is to set the tmpDirectory configuration key with an ASCII-only path before the program start-up.
Solution
Modify a path to your virtual machines.
To modify a path, proceed as follows:
- In vCenter, select Edit.
- Select Preferences.
- In the Preferences property box, switch to the Workspace tab.
- In the Default location for virtual machines and teams field, specify the new pathname using ASCII characters only.
- Once you are done, click OK.