ESXi Server/vCenter Error (code 1910)
Situation
A VMware backup plan terminates with the following error: ESXi Server/vCenter Error
Cause
This error occurs on the ESXi server side and may have different reasons which cannot be defined on the MSP360 Backup side.
Solution
Usually, reading vCenter logs leads to an error determination and appropriate solution linked to the error.
Using the Log Browser to View, Search, and Export Logs for Troubleshooting
You can view, search, and export one or more vCenter Server and ESXi log files at a time using the log browser. You can also export, manage, and view different log types.
Log browser is a plug-in to the vSphere Web Client and is part of the vCenter Server installation package. To use the log browser, you must deploy the log browser plug-in.
If you deploy the log browser plug-in, you can view, search, and export one or more vCenter Server and ESXi log files at a time using the log browser. You can also export, manage, and view different log types.
Log in to vSphere Web Client and provide the credentials. When you are inside the Web Client, you have two ways to navigate to the Log Browser:
- Log Browser for a specific host or vCenter Server.
- Browse Log Files from Different Objects.
Learn how to manage logs in vCenter Server:
- Log Browser for a specific host or vCenter Server
- Browse Log Files from Different Objects
- Search Log Files
- Filter Log Files
- Create Advanced Log Filters
- Adjust Log Times
- Export Logs from the Log Browser
- Manage Logs Using the Log Browser
Log Browser for a Specific Host or vCenter Server
- Navigate to the host or vCenter Server that contains the logs you want to retrieve.
- Click the Monitor tab.
- Click Log Browser.
- (Optional) If no logs for the host or vCenter Server are available, click Retrieve now to retrieve the logs for that object.
- The retrieved logs are based on a current snapshot of the system. Retrieving logs can take a few minutes. You can perform other tasks while the logs are being retrieved.
- (Optional) Click Refresh to retrieve newer logs. Select the type of log you want to browse.
The log is displayed in the browser.
Browse Log Files from Different Objects
You can browse multiple log files coming from different objects within the Log Browser at the same time. This is helpful if you want to simultaneously compare log files.
To do this:
- From the vSphere Web Client home, click Log Browser.
- Click the View tab.
- Select an object (ESXi host or vCenter Server) to open its logs.
- Open a new browser window by selecting Actions > New Browser Window and select another object to open its logs.
There are various options available through Log browser, some are them are mentioned below:
- Search Log Files
- Filter Log Files
- Create Advanced Log Filters
- Adjust Log Times
- Export Logs from the Log Browser
- Manage Logs Using the Log Browser
Search Log Files
You can search the log files by text or by time.
If the log is unavailable, you must retrieve it. Click Retrieve now to retrieve the logs for that object
To search for logs:
- Navigate to the Log Browser.
- Select the type of log you want to browse.
- In the Actions menu, select either Find by Text or Find by Time.
- In the search area at the bottom of the Log Browser type the text or select the time you want to search.
- Click Next to view the next line containing the text or time searched or Previous to view the previous line.
The Log Browser displays the line (in the 3rd row) that contains the text or time you searched.
Filter Log Files
The Log Browser displays filtered searches.
To filter log files:
- Navigate to the Log Browser and select a log file to browse.
- Select the number of Adjacent lines you want the Log Browser to display.
- Type the text that you want to be filtered in the search box.
- When displaying adjacent lines, groups of consecutive entries are highlighted with a different background color.
The log browser displays the lines in the log that contain the word you typed, along with the number of adjacent (before and after) lines.
Create Advanced Log Filters
You can create and save log file filters to your local system.
To do this:
- Navigate to the Log Browser and retrieve a log file object.
- Click the Advanced filter.
- Enter the conditions you want to be included in the filter.
- Type a filter name.
- Click Save to save the filter. The filter is saved on the vSphere Web Client server and is available the next time you start the vSphere Web Client.
- Click Filter to view the results in the Log Browser.
What to do next: You can load saved filters from your local system by clicking Save to a local system. The filters are saved in XML format. You can also load filters from an XML file from your local system by clicking Load from a local system
Adjust Log Times
You might want to adjust the times in the log files to a different time zone or to compare multiple log files.
To do this:
- Navigate to the Log Browser and retrieve a log file from an object.
- In the Actions menu, select Adjust by Time.
- Select Add or Subtract and adjust the days, hours, minutes, seconds, or milliseconds from the original timestamps in the log. The adjusted time stamp appears. (Optional) Click Reset to adjust the timestamp back to the original times. Click Apply.
The log browser displays the log entries with the adjusted times.
Export Logs from the Log Browser
You can export log files using the Log Browser. To do this:
- Navigate to the Log Browser and select an object to browse.
- Select Action > Export.
- Select the type of file that you want to export. Selecting the log file bundle downloads a potentially large file.
- Click Export. After a few seconds a new web browser displays.
- Enter the location where you want to save the file.
- The log file is downloaded to your local machine and you can close the new browser window.
Manage Logs Using the Log Browser
From the Log Browser, you can update, remove, and see a list of available log file bundles. To manage log file bundles, you must access the Log Browser from the vSphere Web Clienthome.
- From the vSphere Web Client home, click Log Browser.
- Click the Manage tab.
- Select an object's log file in the list of sources.
- (Optional) Click Remove to delete the log file bundle. Deleting the log file bundle reclaims disk space on the vSphere Web Client server. All log files generated from that bundle are deleted.
- (Optional) Click Update to update the list of log file bundles. You can view the log bundles created by other vSphere Web Client sessions.
The log does not appear in the retrievable objects list.