Unsupported Symbols in Filenames (code 3009)
Applies to the legacy backup format only
Situation
Upon a backup plan execution, the following error occurs: Unsupported symbols in filenames.
Cause
Filenames in backup source contain unsupported symbols by the cloud storage. They may differ depending on which cloud provider is used.
Solution
There are several basic methods to solve the issue.
Create The Backup Plan in New Backup Format
Create the new backup plan in Backup Agent(standalone users/managed backup users) or in Management Console for the same scope (files and folders) in new backup format. Reshedule the original files backup plan. On the Schedule step, select to run this plan manually. It is possible to convert (upgrade) plan in legacy backup format to the new backup format as described here by means of CLI command.
Use Image-based Backup Type Instead of File-level Backup
To learn more about the image-based backup, refer to the Image-Based Backup section of the help documentation.
Rename Files Containing Unsupported Symbols
Renaming files with unsupported symbols can appear as the easiest solution to this issue.
Note that unsupported symbols are storage-sensitive
To learn more about different storage limitations:
- For Microsoft Azure, refer to the Unsupported Characters for Microsoft Azure article
- For Backblaze B2, refer to the Unsupported Characters for Backblaze B2 article
- For Wasabi, refer to the Unsupported Characters for Wasabi article.