Cannot Specify All Azure Virtual Machine Instance Details In Restore Wizard
Situation
Let’s say you have one copy of your image in the cloud and you need to perform a restore to Azure VM. You select the data for restore and your account but you cannot select some of your resources: you can not list your network, subnet, storage, and/or your container(s).
Causes
- First reason: specified location.
Make sure that you’ve selected the right region (where you have all your resources created). And make sure that the Virtual Network, Storage, and Container are created in the same region.
- Second reason: you are using Classic Deployment (Classic Azure Portal), but not Resource Manager (New Azure Portal).
CloudBerry Backup supports only Resource Manager for restoring virtual machines. If you are using Classic Deployment and you have the Virtual Network, Subnets, Storage, and Containers created in the old portal, you won’t be able to list them in the Cloudberry restore wizard.
It’s not a problem since you can log in to the Resource Manager. Then add Storage, Containers, and Virtual Network under your resource group. Don’t forget that all these resources should be in one location (region). Once you added all the necessary resources, return back to the restore wizard, complete filling out the instance details, and finish the restore.
Contact Us
- Tech questions
- Sales questions: sales@msp360.com