Full Backup Postponed (code 1533)

Situation

A backup plan finishes with the following info message: Full backup postponed. Intelligent Retention postponed the creation of the next full backup. It will be created after the early deletion fee period expires for the existing full backup. Backup plan will continue scheduled incremental backups

Cause

This info message occurs in backup plans with enabled Forever Forward Incremental schedule and Intelligent Retention enabled with the incorrect retention settings: the retention period for incremental backup specified in the backup plan is shorter than the minimum retention period defined by the storage provider.

Intelligent Retention works as follows: each time a backup plan is executed, backup storage parameters are checked and the retention period for a Forever Forward Incremental (FFI) backup (with FFI, only one full backup is kept on backup storage) is adjusted in such a way that this full backup is kept on backup storage for a minimum period based on storage provider data deletion conditions.

The next full backup is synthesized from the old full backup copy and incremental backups are merged into it. Then, incremental backups are deleted. So, if you specified a period of keeping incremental backups shorter than the minimum retention period defined by the storage provider, with the Intelligent Retention enabled, a full backup copy will be kept on storage for the minimum retention period set by the storage provider and only then a new full backup will be synthesized.

Thus, for example, this info message will occur if you set the 'Keep backup for' value as 5 days and your backup plan uses Wasabi as backup storage (with 30-day minimum retention).

Solution

Edit the 'Keep backup for' parameter value in the retention settings according to your backup storage data retention periods. To do this, proceed as follows:

  1. Edit the backup plan that failed with this error.
  2. On the Select Backup Storage step, learn which storage provider is used as backup storage.
  3. Check at the storage provider's side the minimum retention period. If you use AWS S3 as the storage provider, note that different storage classes have different minimum retention periods. Remember this value or write it down somewhere.
  4. Follow the backup wizard to the Retention policy step.

  1. Edit the 'Keep backup for' value in such a way that it exceeds the minimum retention period stated defined by your storage provider (and storage class in case you use AWS S3 storage).
  2. Follow the backup wizard to the end to save the backup plan configuration.