Article ID: kb00140Last Modified: 22-Aug-2024

The File Cannot Be Accessed By The System

Situation

A backup plan terminates with the following error message: The file cannot be accessed by the system

Cause

The cause is the WindowsApps folder. This folder is a location for installed Windows desktop applications. It was introduced with Windows 8 and is used as a location for installed Windows Store apps. Read/Write permissions are limited by operation system.

Solution

Exclude Folders Manually

The only way to solve the issue is to exclude these folders from the backup plan.

  1. Open Management Console, then navigate to required backup plan.
  2. Click Edit.

  1. Expand "Backup Source" section and click "Show Plain Text" link. Insert the following folders in the "Exclude Paths" field.
  • %USERPROFILE%\AppData\Local\Microsoft\WindowsApps
  • %USERPROFILE%\AppData\Local\Packages
  • %USERPROFILE%\AppData\Local\Temp

  1. Save backup plan changes.
  2. Run backup plan as usual.

Exclude Folders With The Script

If the backup environment is huge and required too much manual work, use the script to add exclusions.

  1. Download the script.
  2. Run the script on required machines using remote management on Computers or GPO.

Exclusions will be added automatically to all file-level backup plans.


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