VSS Error 22: A Critical VSS Component is Not Registered

Situation

An image-based backup plan fails with an error message similar to this:

2020-01-01 10:00:00,000 [DiskBase] [1] ERROR - Start backup for disk 111111-2222-3333-4444-555555 \\?\Volume{222222-3333-4444-5555-666666} \\?\Volume{333333-4444-5555-6666-000000}
Alphaleonis.Win32.Vss.VssUnexpectedProviderErrorException
The provider returned an unexpected error code.

In the Windows “System” event log, the error is listed as follows:

VSS Error 01/01/2020 10:00:00 PM EventID: 22
Volume Shadow Copy Service error: A critical component required by the Volume Shadow Copy service is not registered. This might happened if an error occurred during Windows setup or during installation of a Shadow Copy provider. The error returned from...

Cause

This error has a range of possible reasons, including the absence of a certain VSS component (writer / requestor) or usage of a 32-bit VSS requestor on a 64-bit Windows OS.

Solution

  1. Open the MSP360 Backup application.
  2. Make sure the Backup Service is run under the local administrator account.
  3. In the Tools menu, click Change Service Account, then specify the local administrator account credentials.
  4. Click OK. The Backup Service will restart automatically.
  5. Switch to the Backup Plans tab, then edit the image-based plan that was failing with this error
  6. On the Select Partitions step, make sure that the UseVSS option is enabled for all partitions selected for backup.

  1. Follow the backup wizard to the Advanced Options step, then check the box for Use system VSS provider.

  1. Follow the backup wizard steps to save changes. Do not run the backup plan yet.
  2. Before you execute the backup plan, ensure that all core VSS components on your source instance are re-registered. To do this:
  • Open an elevated command prompt, then run the following commands:
    • chdir “C:\Program Files\CloudBerryLab\Online Backup”
    • .\cbb.exe fixVSS -output full

Wait for the command output and close the command prompt window.

If the path does not exist, this means that the application is installed to a different location in your system. You can right-click the Online Backup shortcut, then follow through with the Open file location option to find out the path to use instead.

If the error persists, contact our support team

To learn more about VSS, refer to the VSS Shadow Copy Creation and Storage Space Availability article.

https://git.cloudberrylab.com/egor.m/doc-help-kb.git