VSS Error 8194: Access Denied

Situation

An image-based or VM backup plan fails with an errors in logs similar to the ones below:

2020-01-01 10:00:00,000 [PL] [1] ERROR - Error on backup completed snapshot. SnapshotCreated: False
Alphaleonis.Win32.Vss.VssBadStateException
The VSS object was in an incorrect state for the requested operation.

or:

2020-01-01 10:00:00,000 [SERV] [1] ERROR - Backup failed
CloudBerryLab.Backup.Engine.Utils.VSS.WriterStatusException
'Microsoft Hyper-V VSS Writer' writer status is invalid. State: FailedAtPrepareSnapshot, Failure: WriterErrorNonRetryable

If you refer to the Windows System event log, the following error may be present:

VSS Error 01/01/2020 10:00:00 PM EventID: 8194
Volume Shadow Copy Service error: Unexpected error querying for the IVssWriterCallback interface.  hr = 0x80070005, Access is denied.
. This is often caused by incorrect security settings in either the writer or requestor process.

Cause

The Windows NETWORK SERVICE predefined local user does not have sufficient access permissions on the machine backup is executed.

Solution

To grant the required permissions, proceed as follows:

  1. Open the Windows Start Menu, then run dcomcnfg tool.
  2. Expand the path Console Root => Component Services => Computers.
  3. Right-click on My Computer, then select Properties.

  1. In the My Computer Properties dialog box, switch to the COM Security tab.

  1. In the Access Permissions group, click Edit Default....
  2. In the Access Permission dialog box, click Add...

  1. In the Enter the objects name to select field of the Select Users, Computers, Service Account or Groups dialog box, specify the service name: Network Service, then click Check Names.

  1. Click OK.
  2. In the Default Security group of the Access Permission dialog box, select NETWORK SERVICE.
  3. In the Permission for NETWORK SERVICE field, select the Local Access -> Allow check box.

  1. Click OK, then save changes and close all open dialog windows.
  2. Open Backup for Windows .
  3. Switch to the Tools menu, then click Change Service Account.
  4. In the CloudBerry Backup Service Account dialog box, specify the local administrator credentials, then click OK. The Backup Service restarts automatically.
  5. Restart your computer, then run the backup plan again.
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