I/O error returned from the location where the repository is stored (code 1076)

Situation

A backup or restore plan failed with the following error message: I/O error returned from the location where the repository is stored.

The path to the location is reported in the error message.

Cause

This error will be reported when the hard drive or SSD is damaged, unstable, or the repository file is corrupted.

Solutions

  1. Change the location where repository is stored
  2. Delete and create repository again

Solution 1. Change the location where repository is stored

  1. Run the Backup Agent.
  2. In the application menu, select Options.
  3. Switch to the Repository tab.

  1. Specify the path to a new repository database location in the Location field or browse for the required folder using the button.
  2. To specify low disk space notification, select Enable low disk space alert check box and specify the threshold using the Threshold spin box. The repository file will be copied in the new location as is. In case the repoditory file is corrupted you will need to delete it manually, and then run the Backup Agent Again to recover the file.

Solution 2. Delete and create repository again

  1. Run the Backup Agent.
  2. In the application menu, select Options.
  3. Switch to the Repository tab.

  1. Copy the path to the repository database location.
  2. Close the Backup Agent.
  3. Stop the following services using Task Manager
    • For Managed Backup - Online Backup Service and Online Backup Service Remote Management
    • For MSP360 (formerly CloudBerry) Backup - CloudBerry Backup Service.
  4. Delete the repository file using the copied repository database location.
  5. Start the following services again using Task Manager
    • For Managed Backup - Online Backup Service and Online Backup Service Remote Management
    • For MSP360 (formerly CloudBerry) Backup - CloudBerry Backup Service.
  6. Run the Backup Agent again.
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