Files in Long-term Storage Were Detected (code 1532)
Situation
A backup plan finishes with the following error: Files in long-term storage were detected. Current generation files were detected in long-term storage
Cause
This error appears in cases where some files required to be in hot access tiers are in long-term storage (for example, S3 Glacier-Flexible Retrieval storage class). This usually happens due to the lifecycle policy settings, when data is moved to the long-term tiers automatically after the specified retention period.
In the case of Forever Forward Incremental, the Synthetic Full mechanism is used to rebuild a full backup. Synthetic Full cannot work with data located in long-term storage. Therefore, Forever Forward Incremental is not supported if some data is in long-term storage.
Solutions
If you want to continue using long-term storage:
- Change your backup plan schedule from "Simple" (Forever Forward Incremental) schedule to "Advanced" (Recurring).
If you are ready to change your backup storage destination:
- Replace the existing storage destination with with a tier that supports Synthetic Full, then force a full backup in the backup plan.
Edit Backup Plan Schedule
To edit an existing backup plan schedule:
- On Computers select Remote Management if you use the legacy main menu, or open Backup > Computers page in the new main menu.
- Find the required computer, then click the Configure icon in the Backup Plan Status column.
- On the side panel, expand the plan you want to edit, then click Edit.
- Proceed to Schedule step to change the schedule.
- Once you have made the required changes, click Save.
Edit Backup Destination
To edit the backup destination for a backup plan:
- On Computers select Remote Management if you use the legacy main menu, or open Backup > Computers page in the new main menu.
- Find the required computer, then click the Configure icon in the Backup Plan Status column.
- On the side panel, expand the plan you want to edit, then click Edit.
- Proceed to Where to Back Up step to change the existing backup destination to the destination where the data will not be moved to long-term storage. Confirm your selection.
- Once you have made the required changes, click Save.
How to Force a Full Backup
To force a full backup after changing the storage destination:
- Expand actions to force full backup for the backup plan: