Files in Long-term Storage Were Detected (code 1532)
Situation
A backup plan finishes with the following error: Files in long-term storage were detected. Current generation files were detected in long-term storage
Cause
This error appears in cases when some files required to be in hot access tiers are in long-term storage (for example, S3 Glacier-Flexible Retrieval storage class). This usually happens due to the lifecycle policy settings when data is moved to the long-term tiers automatically after the specified keeping period.
Forever Forward Incremental is not supported if some data is in long-term storage.
Solution
To avoid such situations, check your lifecycle rules in the storage account.
MSP360 (formerly CloudBerry) Backup
For AWS S3, proceed as follows:
- Click Tools.
- Click Lifecycle Rules.
- Select the storage account that is specified in the backup plan that produced the error.
- Unselect the required check box on the bucket or the backup prefix to unapply lifecycle rules.
- Click OK.
Managed Backup
- Open the Management Console.
- On Storage select the Storage Accounts item if you use legacy main menu, or open Backup > Storage Accounts page in the new main menu.
- Select the storage account you want to check.
- Click on the gear icon to the right of the storage account.
- Click on the Lifecycle Rules Settings
- Make changes, if necessary. Click OK
If you use Microsoft Azure as the backup storage, refer to the Configure a lifecycle management policy chapter to learn how to modify the lifecycle policy for your backup destination