Article ID: kb1012Last Modified: 13-Oct-2024
Storage Account Is Not Specified (code 1012)
Situation
A backup or restore plan failed with the following error message: Storage Account is not specified (code 1012)...
Cause
This error occurs when the storage account previously assigned to a company/user is no longer available for the backup plan, and the Backup Agent cannot access this destination to perform backups.
This issue may lead to stale backups, which could require manual deletion if the data is no longer needed
How to Handle This Issue
Accidental Removal: If the storage account was removed by mistake:
- Verify whether the storage account still exists and you have access to this storage account.
- Add this storage account again (Managed Backup or MSP360 Backup)
- Assign the account again to the company/user (Company in Managed Backup or User in Managed Backup).
- Start the affected backup plan manually (Managed Backup or MSP360 Backup)
Intentional Removal: If the storage account was removed intentionally:
- Edit the affected backup plan to select a different storage account for future backups.
- If you still have access to the removed storage account, review any unnecessary backups and delete them if they are no longer needed.
You can use the MSP360 Explorer (https://www.msp360.com/explorer/), our cloud file manager, to delete any unnecessary backups manually. Refer to MSP360 Explorer documentation for details.