Article ID: kb00331Last Modified: 06-Oct-2026

.Net Framework machine.config File Issue on Backup Service Start

Situation

The Backup Service hung on start with the following error message:

"<Timestamp>" [Scheduler] [Initialization] ERROR - Failed to start remote server
System.Configuration.ConfigurationErrorsException
The type 'Microsoft.VisualStudio.Diagnostics.ServiceModelSink.Behavior, Microsoft.VisualStudio.Diagnostics.ServiceModelSink, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a' registered for extension 'Microsoft.VisualStudio.Diagnostics.ServiceModelSink.Behavior' could not be loaded. (C:\Windows\Microsoft.NET\Framework64\v4.0.30319\Config\machine.config line 233)

Cause

This error occurs when the .Net Framework machine.config file contains a reference to a missing DLL.

How to Handle This Issue

  1. Stop the Backup and RMM services.
  2. Find the C:\Windows\Microsoft.NET\Framework64\v4.0.30319\Config\machine.config file on the affected computer.
  3. Edit the file to remove the following section:
<system.serviceModel>
    <extensions>
        <behaviorExtensions>
            <add name="Microsoft.VisualStudio.Diagnostics.ServiceModelSink.Behavior" type="Microsoft.VisualStudio.Diagnostics.ServiceModelSink.Behavior, Microsoft.VisualStudio.Diagnostics.ServiceModelSink, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a"/>
      </behaviorExtensions>
    <extensions>

<commonBehaviors>
    <endpointBehaviors>
        <Microsoft.VisualStudio.Diagnostics.ServiceModelSink.Behavior/>
    </endpointBehaviors>
    <serviceBehaviors>
        <Microsoft.VisualStudio.Diagnostics.ServiceModelSink.Behavior/>
    </serviceBehaviors>
</commonBehaviors>
</system.serviceModel>
  1. Save the file.
  2. Start the Backup and RMM services again.
https://git.cloudberrylab.com/egor.m/doc-help-kb.git
Production