Not enough space for a VSS snapshot (code 1037)
Situation
Backup plan fails with the following error Not enough space to create VSS snapshot.... A VSS snapshot requires free space on the source volume to operate or to be created. On a completely idle volume, the snapshot will consume a minimal amount of space. However, if data is modified, deleted, or added to the volume while the snapshot exists, the snapshot's storage needs can grow significantly, potentially leading to a failure. This error can be generated: At a VSS snapshot creation:

If the space tun out for existing VSS snapshot:

Example Scenario
Have a look to the example scenario:
- You have a volume H: with a total size of 10 GB.
- It is 95% full (9.5 GB used, ~500 MB free).
- Creating the initial snapshot will succeed. However, consider this subsequent activity:
- You delete ~400 MB of data from the volume.
- You then copy ~400 MB of new data to the volume. This sequence can trigger the following error: There was insufficient disk space on volume H: to grow the shadow copy storage for shadow copies of H:. As a result of this failure, all shadow copies of volume H: are at risk of being deleted.
Cause
Errors of this type generally arise due to insufficient disk space for shadow copies on one or more Windows OS volumes during a backup plan execution. In some cases, system reserved partitions cause a significant shadow copy volume increase. To learn more about VSS snapshots, refer to the Volume Shadow Copy Service section at docs.microsoft.com.
The initially available 500 MB of free space is insufficient to track the changes from the delete and copy operations. The snapshot needs to preserve the old data that was modified or deleted, leading to the space shortage.
Solutions
- Free up as much disk space as possible on the source volume before running backup plans that rely on VSS.
- If possible, pause or reschedule heavy file operations (large deletions, copies, or writes) for the duration of the backup plan's execution.
- Manage storage space available for a VSS snapshot
On a Server OS
To resolve the insufficient storage space issue on instances running on server OS (Windows Server etc.), proceed as follows:
- Click Start, then click This PC.
- In the Drives and Devices section, right-click on a required drive.
- In the context menu, select the Configure Shadow Copies... item.

- In the Shadow Copies properties box, view the list of volumes. If the Used column is blank, it means no storage space is currently allocated for shadow copies.

- To allocate the storage space for shadow copies, select the source volume for shadow copies, then click Settings.
- In the Storage area box, select the target volume for shadow copies, then specify the shadow copy size limit or select the No limit option if you want to keep the storage space for shadow copies unlimited.
It is recommended to allocate at least 30% of the volume to shadow copies. To learn more, refer to the Volume Shadow Copy Service article at docs.microsoft.com
- Once you are finished, click OK, then run your backup plan again to make sure the error would not occur again.

On a Desktop OS
To resolve the insufficient storage space issue on instances running on desktop OS (Windows 7, 10 etc.), proceed as follows:
- Open an elevated command prompt (cmd)
- In the cmd console, run the following command: vssadmin resize shadowstorage /on=x: /for=x: /maxsize=30%
The /on parameter specifies the target volume for the shadow storage. The /for parameter is the source volume of the storage. The /maxsize parameter specifies the maximum size for the shadow storage area on a volume.
It is recommended to have at least 30% of space available for shadow copies. To learn more, refer to the vssadmin resize shadowstorage article at docs.microsoft.com