Article ID: kb10133Last Modified: 16-Aug-2024

Shadow Copy Is Missing (code 1712)

Situation

An image-based backup plan terminates with one of the following events:

  • Shadow copy is missing (code 1712)

Cause

This error is caused if the shadow copy is removed by user or by system due to insufficient disk space for shadow copies on one or more Windows OS volumes during backup plan execution. In some cases, system partitions cause a significant shadow copy volume increase. To learn more about VSS snapshots, refer to the Volume Shadow Copy Service section at docs.microsoft.com.

Solution

If the shadow copy is deleted by user, run the backup plan again If the shadow copy is deleted by system, use one of solutions below.

Delete old shadow copies. To do this, proceed as follows:

  1. Open an elevated command prompt (cmd)
  2. In the cmd console, run the following command: vssadmin delete shadows /all

To learn more about vssadmin command, refer to the vssadmin section at docs.microsoft.com

If the issue persists after deleting old shadow copies, you will need to expand the storage available for shadow copies.

On a Server OS

To resolve the insufficient storage space issue on instances running on server OS (Windows Server etc.), proceed as follows:

  1. Click Start, then click This PC.
  2. In the Drives and Devices section, right-click on a required drive.
  3. In the context menu, select the Configure Shadow Copies... item.

  1. In the Shadow Copies properties box, view the list of volumes. If the Used column is blank, it means no storage space is currently allocated for shadow copies.

  1. To allocate the storage space for shadow copies, select the target volume for shadow copies, then click Settings.
  2. In the Storage area box, select the target volume for shadow copies, then, specify the shadow copy size limit or select the No limit option if you want to keep the storage space for shadow copies unlimited.

It is recommended to allocate at least 30% of the volume to shadow copies. To learn more, refer to the Volume Shadow Copy Service article at docs.microsoft.com

  1. Once you are finished, click OK, then run your backup plan again to make sure the error would not occur again.

On a Desktop OS

To resolve the insufficient storage space issue on instances running on desktop OS (Windows 7, 10 etc.), proceed as follows:

  1. Open an elevated command prompt (cmd)
  2. In the cmd console, run the following command: vssadmin resize shadowstorage /on=x: /for=x: /maxsize=30%

The /on parameter specifies the target volume for the shadow storage. The /for parameter is the source volume of the storage. The /maxsize parameter specifies the maximum size for the shadow storage area on a volume.

It is recommended to have at least 30% of space available for shadow copies. To learn more, refer to the vssadmin resize shadowstorage article at docs.microsoft.com

https://git.cloudberrylab.com/egor.m/doc-help-kb.git