Article ID: kb00363Last Modified: 30-Apr-2026

VSS in Full Mode Is Used. How to Resolve the Issue (code 1976)

Situation

The following info messages is reported:

  • (Code 1976) VSS full mode is used (ProxmoxGuestToolsVssNotBtCopyConfiguredException) A VSS snapshot was created using the Full backup type. Some applications (e.g., SQL Server, Exchange) may not be backed up correctly. List of these affected VMs is reported.

Cause

The Volume Shadow Copy Service (VSS) is not configured correctly for Proxmox backups. Configure VSS correctly for MS SQL and Exchange backup plans and run them again. The rest of backup plans can work normally.

Solution

Verify the Current Value: Open the Registry Editor (regedit) on your Windows VM and navigate to the key path (HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\QEMU Guest Agent VSS Provider). Check the current numerical data for the VssOption value.

Set to VSS_BT_COPY (Value 5): To prevent the Proxmox host backups from interfering with any backup software running inside your Windows guest, you should set this value to 5.

  • Right-click on VssOption and select Modify.
  • In the "Value data" field, change the number to 5.
  • Ensure the "Base" is set to Decimal.
  • Click OK.

If the VssOption value does not exist, you can create it by right-clicking in the right pane, selecting New > DWORD (32-bit) Value, naming it VssOption, and then setting its value to 5.

Reboot the VM: For the change to take effect, you must fully reboot your Windows VM.

Fallback Behavior: It's important to note that if the VssOption value does not exist or is set to an invalid number, the QEMU Guest Agent will default to VSS_BT_FULL (value 1)

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