Damaged VMs (code 1928)

Situation

A Hyper-V backup plan terminates with the following warning: Damaged VM(s). Cannot create the checkpoint(s). One or more VMs are damaged. View the list of damaged VMs below with the list of VMs detected as damaged.

Cause

The occurrence of this warning means that some VMs on your Hyper-V environment is detected as damaged: generally, this means that one or more processes running on VM are stuck. For these VMs a checkpoint cannot be created.

Solution

Try to figure out the process(es) that make the VM damaged and kill them.

To do this, proceed as follows:

  1. Identify the GUID of the stuck VM you want to kill, you can use the virtual machine management tool Hyper-V Manager and Windows File Explorer.
  2. In Hyper-V Manager, in the left pane, under Hyper-V Manager, right-click the name of your Hyper-V host then click Hyper-V Settings.
  3. In the Hyper-V Settings window that opens, in the left panel under Server, click Virtual Machines. The default destination of your VMs is displayed under Virtual Machines on the right.
  4. In File Explorer, browse to the destination folder found above. In the VMs folder, look for the folder named after your problematic VM and open it.
  5. In the folder that opens, there is one subfolder and other files carrying identical names (Example: 3B4665937-A799-4242-B76E-FE69478B8579). That name consisting of digits and letters is the GUID of your problematic VM.
  6. Press Ctrl+Alt+Delete and click Task Manager.
  7. Go to the Details tab, and locate the vmxp.exe process that has the GUID found above listed under the User name column.
  8. Click the vmxp.exe process and at the bottom click End Task.
  9. In the Task Manager window, click End Process.

Even after successfully ending the process of your problematic VM, you may still receive the Virtual Machine Connection: Failed to Change State error message when trying to start the VM in Hyper-V.

The Failed to Change State error is commonly caused by a few technical reasons related to storage failure, incorrect network configuration, a conflict in routing and remote configuration, and insufficient permissions to access VM files among others.

https://git.cloudberrylab.com/egor.m/doc-help-kb.git