Retention Policy Cannot Be Applied (code 1537)

Situation

The following warning is reported during the backup plan creation or editing: Retention policy cannot be applied (Code: 1537)

Description: Full backup is not scheduled. A retention policy can only be applied after a full backup or if Forever Forward Incremental is enabled. To avoid this issue, you should schedule a full backup or change your retention policy.

Cause

This warning is reported because customer has no full backup schedule but set a retention policy. This will result in data being kept forever which is not expected.

Solutions

  1. Edit schedule. Set full backup schedule. Your retention policy fill be applied as configured.
  2. Edit schedule. Use Forever Forward Incremental schedule. This schedule sets one full backup followed by chain of incremental ones. The full backup is being updated using incremental backups for which the retention period is expired.
  3. Edit retention policy. Set 'Do not purge' in case you really want to keep backup data forever.
https://git.cloudberrylab.com/egor.m/doc-help-kb.git