Article ID: kb00001Last Modified: 21-Aug-2024

Consistency Check Warnings (codes 2503, 2504, 2505)

Situation

A backup plan terminates with one of the following warnings:

  • Backup from another computer(s) with the same prefix detected and marked as forbidden. Backups to the same backup destination with the same backup prefix from different computers at the same time are not allowed. A full backup was forced
  • Another computer marked current backup as forbidden. Backups to the same backup destination with the same backup prefix from different computers at the same time are not allowed. A full backup was forced
  • Consistency Check detected an issue. Generation number collision due to simultaneous backups from cloned instances

Cause

All these warnings (codes 2503, 2504, and 2505) have a common cause. In some cases, two or more backup plans can run simultaneously and back up different data to the same destination.

This may invoke restore conflicts because similar restore points are created in the same backup destinations for different computers. If Consistency Check detects this situation, one of the restore points is marked as 'forbidden', and a full backup is forced to avoid data interference. If a 'forbidden' restore point is detected, this also forces a full backup for the other computer (warnings 2503, 2504).

Since it is not possible to determine unambiguously which computer created the generation (sequence of full and incremental backups) on backup storage, a new generation is created with a full backup.

To learn more about the generations, restore points, and new backup format in general, refer to the New Backup format section of the help documentation

Solution

Change the backup prefix. By changing the backup prefix, you change the directory on backup storage, so backup data will be kept in the other location on backup storage.

  1. Find out which storage account is used for the plans that produced these warnings. The storage account name is written under the plan name on the Backup Plans tab.
  2. Expand the application menu, select Edit Storage Accounts.

  1. Select the required account, click Edit.
  2. Click Advanced Settings.
  3. In the Backup prefix field, specify an original backup prefix name.

  1. Click *OK.

To learn more about backup prefixes in Managed Backup, refer to the following chapters:

https://git.cloudberrylab.com/egor.m/doc-help-kb.git