Article ID: kb00042Last Modified: 21-Aug-2024

Removing Backup Data of Discontinued Instances

Situation

The backup data affiliated with already retired machines of certain MBS users is still kept in cloud storage, taking space and affecting billing.

Cause

The need to remove (purge) the backup data of retired machines can emerge when:

  • The instances are completely retired and cloud data for them is no longer valuable;
  • Data migration from retired instances to new ones was completed, and the new instances are already backed-up.

Solutions

Data removal from "Organization" -> "Users" menu:

The most basic method to delete unnecessary data of Managed Backup Service users is to utilize "Users" menu:

  1. Open your Management Backup Service web console.
  2. In the Organization menu, select Users.
  3. Find the user account that needs to be deleted, then click X button.

  1. Select one of the available options (listed in the order of appearance on screen):
  • Delete MBS user account from the web-console and keep all associated backed up data;
  • Delete MBS user account alongside all associated backed up data;
  • Delete only the backup data associated with selected instances but keep MBS user account intact.

Note that data removal operations cannot be canceled after initiation and, in some cases, they might take up to 96 hours to complete (depending on cloud storage provider and storage class). MBS user account deletion cannot be canceled either.

Data removal from "Reporting" -> "Capacity Report" menu:

For MSPs who rely on MSP360 cloud storage it could be of convenience in certain situations to utilize "Capacity Report" menu for removal of redundant backup data:

  1. Open your Management Backup Service web console.
  2. In the Reporting menu, select Capacity Report;
  3. Navigate to storage account and MBS user associated with backup data that needs to be deleted;
  4. Initiate deletion of backup data for retired machine(-s):

Note that "Capacity Report" data deletion method is currently only applicable to data stored on MSP360 cloud storage (powered by AWS or Wasabi), not to data stored on any other cloud storage, and not to locally stored data.

Additional methods of backup data deletion

To delete backup data selectively on active (not retired) machine / instance:

  1. Open Backup Agent software directly on the machine;
  2. Switch to the Backup Storage tab;
  3. Right-click on the backup object that needs to be deleted, then press Delete button:

Please exercise discretion, and also note that this feature may be unavailable for specific backup objects, such as SQL database backups.

To delete objects manually using MSP360 Explorer tool (use version compatible with your cloud storage provider):

  1. Download MSP360 Explorer tool.
  2. Specify credentials for your cloud storage.
  3. Browse cloud storage contents and delete unnecessary data.

Be extra careful not to remove critical data accidentally. These deletions are not reversible. MSP360 is not responsible for any data deleted manually.

Note that using this manual method, should you delete any backed up objects from a cloud storage, Backup applications will not track changes in destination storage until data listing in the repository database is synchronized.

To Synchronize Repository:

  1. Open Backup Agent software;
  2. In the Tools menu, select Options;
  3. Switch to Repository tab, then click Synchronize Repository.

To learn more about this procedure, refer to the Repository Explained article.

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