Object Lock (Immutability) Is Not Supported (code 2523)
Situation
A backup plan terminates with the following error: Object Lock (Immutability) is not supported. The storage account in this backup plan does not support Object Lock (Immutability) (code 2523).
Cause
The occurrence of this error means that the storage account does not support the Object Lock (Immutability).
Solution
In Managed Backup
The easiest way is to create a new bucket with Object Lock (Immutability) support. If you are provider or administrator with enough privileges, proceed as follows:
Consider that the Object Lock (Immutability) option currently must be allowed by means of Management Console. Default Object Lock (Object Lock (Immutability) options enabled directly by means of management web consoles belonging to backup storage providers (AWS S3, Wasabi, BackBlaze)) cannot be currently supported.
If you need to comply with the regulations, maintenance or legal requirements, or anything else that requires an immutable backup dataset, enable this feature for an appropriate storage account.
If you do not have any storage destinations with the allowed Object Lock (Immutability), you can create a new destination bucket in Management Console. You can use also an existing bucket with Object lock (Immutability enabled through Management Console).
To use the Object Lock (Immutability) feature, appropriate permission must be granted to the account used for backup storage connection. For example, for S3 destinations, GetBucketObjectLockConfiguration permission must be granted
- Open the Management Console.
- In the Storage > Storage Accounts select the required account.
- Expand actions and click Add backup destination.
- In the Destination display Name field, specify the backup destination name.
- Select the New bucket option.
- Name the bucket.
- Select the required region.
- Turn on Enable Object Lock (Immutability), then confirm the action in the dialog box.
- Click Save.
- Edit the backup plan that produced this error (code 2523) and specify for it the new backup destination created on steps 2-10.
In Backup for Windows
To do this, proceed as follows:
- In the application menu, select Edit Storage Accounts.
- Select the required storage account, then click Edit.
- In the Bucket Name field of the Storage Account tab, select Create New Bucket.
- In the Create Bucket dialog box, specify the bucket name, then select the Enable Object Lock (Immutability) checkbox.
Note that you can only enable Immutability for new buckets. If you want to enable Object Lock (Immutability) for an existing bucket, contact your storage provider Support