The Backup application window loads as an empty frame

Situation

After the start of the MSP360 Backup / Online Backup software, its graphical user interface (GUI) doesn’t load. Sometimes only the empty frame of the window can be seen, with no further progress:

Cause

The issue is usually caused by an incompatible or outdated Visual C++ Redistributable package and/or .NET Framework package version on the system. The outdated graphics hardware drivers could also factor into this problem.

Solution

The following two-step procedure should alleviate the issue:

Update the Backup client software to the latest version

If you are an MSP, please update to the latest version of the Backup client software via your MBS web-console -> "Downloads" tab.

Please make sure to click the “Get newer version” button if it is presented:

If the option to “Allow Automatic Update” is enabled in the “Downloads” tab, the update should be installed remotely and automatically across your managed machines.

If you are user of the standalone (one-time purchase) MSP360 Backup software, you can update the software by downloading the latest version of the Backup software from the MSP360 official website:

https://www.msp360.com/download.aspx?prod=cbbbm&p=backup

Edit the configuration file to switch the product to Software Rendering

After the update, please navigate to the settings folder of the Backup software:

For MBS-based Backup software:

C:\ProgramData\Online Backup*

*Where “Online Backup” (default name) can be replaced with your custom company name, as specified in your MBS web-console -> “Settings” -> “General” -> “Company”.

For standalone (one-time purchase) MSP360 Backup software:

C:\ProgramData\CloudBerryLab\CloudBerry Backup

In this folder, please locate the “enginesettings.list” configuration file and open it for editing with any text editing tool. Find and change the following string from:

<SoftwareRenderMode>false</SoftwareRenderMode>

To:

<SoftwareRenderMode>true</SoftwareRenderMode>

Save the changes to the file. Relaunch the Backup software, the application window should now load properly.

The Backup application will now use the software rendering for GUI instead of the GPU-powered hardware rendering. Thus a certain CPU capacity utilization increase is to be expected, however it should not be significant.

Addendum for MSPs:

Please note that the Backup software agent can be configured specifically to work without the graphical user interface. This can be set up in the MBS web-console -> “Downloads” -> “Advanced Rebranding” (paid feature) -> “Options” tab:

In such a configuration, the Backup software can only be managed remotely via MBS web-console by the MSP, which means that no GUI is present and on-premises command line inputs are not allowed.

https://git.cloudberrylab.com/egor.m/doc-help-kb.git