Activation Failed (code 1034)
Situation
A product (Backup for Windows) activation attempt fails with the following error: Activation failed. The product activation did not succeed due to connection issues
Cause
MSP360 (CloudBerry) Backup uses network connections. Some of them may be restricted by firewalls, antivirus software, or company's security policies. To solve the issue, check the list of allowed connections for Backup for Windows would function properly.
Solution
Offline Activation
If the error persists, try to activate Backup for Windows offline. To learn more about the offline activation, refer to the Offline Activation chapter of the help documentation.
Enable Incoming and Outgoing Connections
Below you can find the list of TCP ports (for both outgoing and incoming connections), domains, and executable files that should be listed as allowed by any firewall or antivirus.
TCP ports:
- 80
- 443
Domains. Domains are storage-specific, so it is reasonable to put in the list of allowed domains only domains for storage providers that you are using:
- For AWS: *.s3.amazonaws.com (full list of endpoints can be found here)
- For Microsoft Azure: *.microsoft.net
- For Google Cloud: www.googleapis.com
- For Backblaze B2: api.backblazeb2.com
- *.mspbackups.com
Executables:
- CloudBerry Backup.exe
- CBBackupPlan.exe
- Cloud.Backup.Scheduler.exe
- cbb.exe
Protocols:
- TLS 1.2 (requires .net 4.5 installed)
The .net 4.5 framework can be installed on instances running on Windows 7 or later Windows versions. In case .net 4.5 cannot be installed, consider to use offline product activation