Cannot Back up. Native Multipart Upload Must Be Enabled for This Backup Format (code 2519)
Situation
A backup plan terminates with the following error: Native multipart upload is disabled. Cannot back up. Native multipart upload must be enabled for this backup format
Cause
The new backup format requires using native multipart upload for S3-compatible storage destinations. Most probably, you have the native multipart upload disabled in your storage account settings.
Solutions
Solution for Management Console
For backup plans in the new backup format, the enabled native multipart uploads are required for S3-compatible storage destinations. Before backing up, mind to make sure if this option is enabled in the storage account settings. To do this, proceed as follows:
- Open the Management Console.
- In the Storage menu, select the Storage Accounts item.
- Find the required storage account, click the Settings icon.
- Select Change Credentials.
- Select the Use native multipart upload checkbox.
- Click Save.
Solution for MSP360 Backup
Note that several S3-compatible storage providers do not support native multipart upload. Check the list of storage providers with no native multipart upload support below:
- Connectria
- Constant
- DDN
- Dunkel
- Hitachi
- Mandic
- Seeweb
Enable native multipart upload. To do this, proceed as follows:
- In the application menu, select Edit Storage Accounts.
- Find the required one, then click Edit.
- On the Storage Account tab, click Advanced Settings.
- In the Advanced Settings property box, select the Use native multipart upload (recommended) check box.
- Click OK.
- Run the backup plan again.