Storage Account Credentials are Invalid or Missing (code 1032)

Solution

A backup plan or restore plan terminates with the following error: Storage Account credentials are invalid or missing

Cause

Typically, this error occurs when MSP360 Backup configuration file was manually modified and some of the storage account strings were deleted or incorrectly modified.

Solution

To solve this issue, update your Storage Account settings.

To Edit Storage Account Settings

  1. In the application menu, select Edit Storage Accounts.
  2. Select the required storage account, then click Edit.

  1. Update all credentials for the storage account.

Note that for different storage providers the Storage Account window has a different interface as well as the credential recovery process can differ. Basically, you must have storage account credentials in a specific file in a secure location. If you do not have, or lost it, learn about credential recovery for the following storage providers:

If your storage provider is not in the list, refer to provider's website

  1. Click OK.
  2. Run the backup or restore plan again.

Restore Amazon S3 Credentials

To get your Access Key ID and Secret Access Key follow next steps:

  1. Open the IAM console.
  2. In the navigation menu, click Users.
  3. Select your IAM user name.
  4. Click User Actions, then click Manage Access Keys.
  5. Click Create Access Key.
  6. Click Download Credentials, then save the keys in a secure location.

Restore Microsoft Azure Credentials

To recover your storage account access keys in the Azure portal, proceed as follows:

  1. Log in to Azure portal.
  2. In Settings, select Access keys.
  3. Your account access keys appear, as well as the complete connection string for each key.
  4. Locate the Key value under key1, and click the Copy button to copy the account key.

Restore Backblaze B2 Credentials

Proceed as follows:

  1. Log in to your Backblaze account.
  2. Select App Keys.
  3. Click Add A New Application Key.
  4. Specify the access to mode (to all buckets or selected bucket).
  5. Click Create New Key.
  6. Copy new application key pair and save them to a secure location.

Restore Wasabi Credentials

To recover your Wasabi credentials, proceed as follows:

  1. Log in to Wasabi Management Console.
  2. Select Access Keys.
  3. Click Create New Access Key.
  4. Select the access key assignment. The following options are available:
  • For Root User
  • For Sub-User
  1. Click Create.
  2. Download the key pair csv file, or copy keys to clipboard.
  3. Save the new credentials to a secure location.
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