Article ID: kb00092Last Modified: 22-Aug-2024
Device Is Not Ready (ERROR CODE 1075)
Situation
Error messages:
- Device is not ready
- I/O error.
Cause
Possible occurrence reasons
- Operating system tries to use a transfer mode that the hardware device cannot use
- Input/output request number by operating system exceeds the hard drive capacities
- The hard drive is damaged
Resolution
In case these errors keep occurring, do the following steps:
- Decrease thread count
- Schedule backup plans for low load periods. Don't run the backup in high load hours (non-working hours are recommended).
To Decrease Thread Count
- Open Backup for Windows.
- In the Tools menu, select Options.
- In the Thread count field, set 2.
- Click OK or Apply.
In case issues occur during image-based backup plans:
- Open the plan that reports these errors, then click Edit.
- Follow the wizard steps to Advanced options, then click Show Advanced Disk Options.
- In the Prefetch block count (0 without prefetch) field, set 50.
- In the Block size drop-down list, select 512 KB.
- Follow the wizard steps to save the plan configuration.
In case you use an external USB drive:
- Reinstall the external disk driver
To Reinstall the Driver
- In the Control Panel, open the Device Manager.
- Right-click your external device, then select Uninstall.
Do not disconnect the external drive
- Restart the instance.
- Windows will attempt to reinstall the driver automatically.
If measures do not bring any effect, the issue is hardware-based. The following steps can be of help:
- Check the S.M.A.R.T. status of the physical drive that is backed up. For example, you can use this tool: http://hdtune.com/
- Use the standard Windows tool chkdsk. To start the tool, open the console, then run the following command: chkdsk {drivename} /f, where {drivename} is a volume of the disk to be scanned