Immutability Is Disabled (code 2524)
Situation
A backup plan is finished with the following warning: Immutability is disabled. Immutability is disabled for the storage account
Cause
This error occurs in one case: the backup plan has the Immutability feature enabled, but the feature is disabled in the storage account settings.
Solution
For Managed Backup
Disable the Immutability feature in the backup plan.
In Management Console
- Open the Management Console.
- On Computers select Remote Management if you use legacy main menu, or open Backup > Computers page in the new main menu.
- Find the computer the error occurred on, then expand actions to view plans.
- Find the backup plan the error occurred in, expand it and click Edit.
- Switch to the Retention Policy step.
- Clear the Enable Immutability check box.
- Click Save.
- Run the backup plan again.
In Backup Agent
- Find the backup plan the error occurred in, click Edit.
- Follow the backup wizard to the Retention Policy step.
- Clear the Enable Immutability check box.
- Follow the backup wizard steps to the end to save the backup plan configuration.
- Run the backup plan again.
For Backup for Windows
First, decide if you need any immutable data in this backup plan. If you still need immutable backups, you can edit the storage account and allow the Immutability back. To do this, proceed as follows:
- In the application menu, select Storage Accounts.
- Find the storage account for the backup plan the error occurred in, then click Edit.
- Select the Allow Immutability check box.
- Switch to the Backup Plans tab, then run the backup plan again.
You can also create a new bucket in the storage account and allow the Immutability for it
- Find the backup plan the error occurred in, click Edit.
- Follow the backup wizard to the Retention Policy step.
- Clear the Enable Immutability check box.
- Follow the backup wizard steps to the end to save the backup plan configuration.
- Run the backup plan again.