Article ID: kb10094Last Modified: 03-Dec-2025
Object Lock (Immutability) Is Disabled (code 2524)
Situation
A backup plan is finished with the following warning: Object Lock (Immutability) is disabled...
Cause
This error occurs in one case: the backup plan has the Object Lock (Immutability) feature enabled, but the feature is disabled in the storage account settings.
Solution
For Managed Backup
Disable the Object Lock (Immutability) feature in the backup plan.
- Open the Management Console.
- In the Computers menu, find the required computer, then click on the computer name.
- In the side panels navigate to the Backup plans tab.
- Edit the required backup plan or create a new one. Remember that the backup plan must be in the new backup format.
- On the Where to back up step of the backup wizard, select the storage account with the Object Lock (Immutability) feature supported.
- Follow the backup wizard to the Retention Policy step.
- Disable the Archive Backups, Grandfather-Father-Son (GFS) feature.

- Follow the backup wizard steps to save the backup plan configuration.
- Click Save.
- Run the backup plan again.