Article ID: kb00068Last Modified: 21-Aug-2024

Error On Starting COM Service (code 2401)

Situation

A backup plan terminates with the following error: Error On Starting COM Service

The event log contains the following event ID: 13.

Cause

This error can be caused by the following issues: COM+ Event System service is not started and/or the Volume Shadow Copy service and Microsoft Software Shadow Copy Provider service are not enabled.

Solution

Note that in some cases several VSS errors can occur at the same time, and the recommendations described below may not be helpful

Follow these best-practice recommendations from Microsoft ©.

Note that the procedures above can be changed by Microsoft. Use the link below to ensure the recommendations are up to date

Refer to the Information about Event ID 13 chapter at docs.microsoft.com

Note that to perform these procedures, you must have membership in Administrators, or you must be delegated the appropriate permissions

Check if the COM+ Event System service is started

To check that the COM+ Event System service is started, proceed as follows:

  1. Click Start, then click Administrative Tools, and then click Services.
  2. In the results pane, double-click COM+ Event System.
  3. In Service status, make sure that the status is Started. If the status is not Started, click Start.
  4. Make sure if the Startup type is set to Automatic.
  5. Click OK.

Check if the VSS service is enabled

To check that the VSS service is enabled, proceed as follows:

  1. Click Start, then click Administrative Tools, and then click Services.
  2. In the results pane, double-click Volume Shadow Copy.
  3. Make sure Startup type is set to Manual.
  4. Click OK.

Check if the Microsoft Software Shadow Copy Provider service is enabled

To check that the Microsoft Software Shadow Copy Provider service is enabled, proceed as follows:

  1. Click Start, then click Administrative Tools, and then click Services.
  2. In the results pane, double-click Microsoft Software Shadow Copy Provider.
  3. Make sure Startup type is set to Manual.
  4. Click OK.

Make sure that third-party installed VSS providers are operating properly

To make sure that third-party installed VSS providers are operating properly, proceed as follows:

  1. Click Start, select All Programs, then select Accessories.
  2. Right-click Command Prompt, then select Run as administrator.
  3. In the command prompt, type vssadmin list providers.
  4. For each provider in the list, use the vssadmin create shadow command to create a shadow copy of the volume for which the provider is responsible. For more information, refer to https://go.microsoft.com/fwlink/?LinkId=105248.

Verify if the VSS is started

To verify that the Volume Shadow Copy Service is started, proceed as follows:

  1. Click Start, then click Administrative Tools, and then click Services.
  2. In the results pane, double-click Volume Shadow Copy.
  3. In Service status, make sure that the status is Started. If the status is not Started, click Start.
  4. Make sure Startup type is set to Manual.
  5. Click OK.

Note that the procedures above can be changed by Microsoft. Use the link below to ensure the recommendations are up to date

Refer to the Volume Shadow Copy Service Operations chapter at docs.microsoft.com

https://git.cloudberrylab.com/egor.m/doc-help-kb.git