VSS Error. The System Cannot Find The File Specified

Situation

An image-based backup plan terminates with the following error: VSS Error. The System Cannot Find The File Specified

Also, in the Application event log the following records can be found:

Log Name:      Application
Source:        VSS
Event ID:      12292
Level:         Error
Description:
Volume Shadow Copy Service error: Error creating the Shadow Copy Provider COM class with CLSID {65ee1dba-8ff4-4a58-ac1c-3470ee2f376a} [0x80080005].

Operation:
   Obtain a callable interface for this provider
   Obtaining provider management interface

Context:
   Provider ID: {b5946137-7b9f-4925-af80-51abd60b20d5}
   Class ID: {00000000-0000-0000-0000-000000000000}
   Snapshot Context: -1
   Provider ID: {b5946137-7b9f-4925-af80-51abd60b20d5}

Log Name:      Application
Source:        VSS
Event ID:      11
Level:         Error
Description:
Volume Shadow Copy Service information: The COM Server with CLSID {65ee1dba-8ff4-4a58-ac1c-3470ee2f376a} and name SW_PROV cannot be started. Most likely the CPU is under heavy load. [0x80080005]

Operation:
   Obtain a callable interface for this provider
   Obtaining provider management interface

Context:
   Provider ID: {b5946137-7b9f-4925-af80-51abd60b20d5}
   Class ID: {00000000-0000-0000-0000-000000000000}
   Snapshot Context: -1
   Provider ID: {b5946137-7b9f-4925-af80-51abd60b20d5}

Cause

This error can occur if the ServiceDll registry value for Swprv is missing or incorrect.

Solution

Before editing the registry, back it up to avoid possible issues. To do this, proceed as follows:

  1. From the Start menu, type regedit.exe in the search box, and then press Enter.
  2. If you are prompted for an administrator password or for confirmation, type the password or provide confirmation.
  3. In Registry Editor, locate and click the registry key or subkey that you want to back up.
  4. Click File > Export.
  5. In the Export Registry File dialog box, select the location to which you want to save the backup copy, and then type a name for the backup file in the File name field.
  6. Click Save.

Once the registry is backed up, proceed to the solution:

  1. Run regedit.
  2. Locate and then click the following registry key: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\swprv\Parameters

If the Parameters registry key is missing, perform the following steps:

Right-click the swprv registry key, select New, select Key, type Parameters, then press Enter

  1. Once the Parameters registry key is selected, make sure that the ServiceDll registry value has the following value: %Systemroot%\System32\swprv.dll

If the ServiceDll registry value is missing, perform the following steps:

  1. Right-click the Parameters registry key, select New, then select Expandable String Value
  2. For the value name, type ServiceDll, then press Enter.
  3. Double-click the ServiceDll registry value.
  4. In the Value Data box, type %Systemroot%\System32\swprv.dll, then click OK.
  1. Once you are done, run the backup plan again.
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